IPC Lagging after Running for a Period of Time
Symptom:
After the IPC had been running for some time, the whole computer had become stuck, but the CPU and memory usage were normal, and the Mech-Vision/Mech-Viz software was functioning normally.
Possible Cause:
The HAGS (Hardware-accelerated GPU scheduling) feature in Windows 11 causes system lagging.
Notes:
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This issue can be reproduced in software versions 2.1.2 and 2.2.0, and is not related to the software version.
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White-box verification confirms that there is no memory-leak issue in Mech-Vision/ Mech-Viz itself.
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Similar lagging behavior has also been reported for other software on Windows 11.
Solution:
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Disable HAGS in Windows settings.
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Open Settings. Press Win + I to open Windows settings.
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Open Graphics Settings. In the search box of System Settings, search for Graphic Settings and click Open.
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Open Advanced Graphics Settings. Click Advanced Graphics Settings.
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Turn off HAGS. Find the Hardware Accelerate GPU Plan in the Advanced Graphics Settings panel and switch its status to OFF.
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Restart the IPC. Restart the IPC to apply the settings.
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If lagging has already occurred, press Win + Ctrl + Shift + B to reset the graphics driver and temporarily mitigate lagging.