IPC Lagging after Running for a Period of Time

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Symptom:

After the IPC had been running for some time, the whole computer had become stuck, but the CPU and memory usage were normal, and the Mech-Vision/Mech-Viz software was functioning normally.

Possible Cause:

The HAGS (Hardware-accelerated GPU scheduling) feature in Windows 11 causes system lagging.

Notes:

  1. This issue can be reproduced in software versions 2.1.2 and 2.2.0, and is not related to the software version.

  2. White-box verification confirms that there is no memory-leak issue in Mech-Vision/ Mech-Viz itself.

  3. Similar lagging behavior has also been reported for other software on Windows 11.

Solution:

  1. Disable HAGS in Windows settings.

    1. Open Settings. Press Win + I to open Windows settings.

    2. Open Graphics Settings. In the search box of System Settings, search for Graphic Settings and click Open.

    3. Open Advanced Graphics Settings. Click Advanced Graphics Settings.

    4. Turn off HAGS. Find the Hardware Accelerate GPU Plan in the Advanced Graphics Settings panel and switch its status to OFF.

    5. Restart the IPC. Restart the IPC to apply the settings.

  2. If lagging has already occurred, press Win + Ctrl + Shift + B to reset the graphics driver and temporarily mitigate lagging.

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