Cameras Function Properly in Mech-Eye SDK, but Cannot Be Found in Mech-Vision

You are currently viewing the documentation for the latest version (2.1.2). To access a different version, click the "Switch version" button located in the upper-right corner of the page.

■ If you are not sure which version of the product you are currently using, please feel free to contact Mech-Mind Technical Support.

Symptom:

The camera could function properly through Mech-Eye SDK, but when the “Capture Images from Camera” Step was used in Mech-Vision, the camera could not be found after clicking the Select Camera button.

Affected Software Versions:

All Mech-Vision versions.

Possible Cause:

  • Mech-Vision was not on the firewall whitelist, and the camera could not be discovered by Mech-Vision due to the firewall blocking.

  • The currently used version of the software is not the stable version of the 1.8 series, i.e., version 1.8.3.

Solution:

  • Follow the steps below to add Mech-Vision to the firewall whitelist:

    1. On the IPC, select Control panel  System and Security  Windows Defender Firewall.

    2. In the left sidebar, click Allow an app or feature through Windows Defender Firewall.

    3. Click Change settings, and then click Allow another app to open the “Add Application” window.

    4. Click Browse in the Add Application window, select “mmind_vision.exe,” and then click Add to add Mech-Vision to the firewall whitelist.

  • If the camera still cannot be found in Mech-Vision after completing the above steps, please check the software version. If you are using the 1.8 series software, please upgrade the software to 1.8.3.

Is this page helpful?

You can give a feedback in any of the following ways:

We Value Your Privacy

We use cookies to provide you with the best possible experience on our website. By continuing to use the site, you acknowledge that you agree to the use of cookies. If you decline, a single cookie will be used to ensure you're not tracked or remembered when you visit this website.