Cameras Function Properly in Mech-Eye SDK, but Cannot Be Found in Mech-Vision
Symptom:
The camera could function properly through Mech-Eye SDK, but when the “Capture Images from Camera” Step was used in Mech-Vision, the camera could not be found after clicking the Select Camera button.
Affected Software Versions:
All Mech-Vision versions.
Possible Cause:
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Mech-Vision was not on the firewall whitelist, and the camera could not be discovered by Mech-Vision due to the firewall blocking.
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The currently used version of the software is not the stable version of the 1.8 series, i.e., version 1.8.3.
Solution:
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Follow the steps below to add Mech-Vision to the firewall whitelist:
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On the IPC, select
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In the left sidebar, click Allow an app or feature through Windows Defender Firewall.
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Click Change settings, and then click Allow another app to open the “Add Application” window.
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Click Browse in the Add Application window, select “mmind_vision.exe,” and then click Add to add Mech-Vision to the firewall whitelist.
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If the camera still cannot be found in Mech-Vision after completing the above steps, please check the software version. If you are using the 1.8 series software, please upgrade the software to 1.8.3.