IPC Lagging after Running for a Period of Time
Symptom:
After the IPC runs for a period of time, the whole system becomes laggy, but the planning and production workflows of Mech-Vision/Mech-Viz can still run normally.
Possible Cause:
The HAGS (Hardware-accelerated GPU scheduling) feature in Windows 11 causes system lagging.
Notes:
-
This issue can be reproduced in software versions 2.1.2 and 2.2.0, and is not related to the software version.
-
White-box verification confirms that there is no memory-leak issue in Mech-Vision/Mech-Viz itself.
-
Similar lagging behavior has also been reported for other software on Windows 11.
Solution:
-
Disable HAGS in Windows settings.
-
Open Settings. Press Win + I to open Windows settings.
-
Go to display settings. In the left pane, select System, and then click Display.
-
Open graphics settings. In "Related settings", click Graphics.
-
Change default settings. Click Change default graphics settings.
-
Turn off HAGS. Switch "Hardware-accelerated GPU scheduling (HAGS)" to Off.
-
Restart the IPC. Restart the IPC to apply the settings.
-
-
If lagging has already occurred, press Win + Ctrl + Shift + B to reset the graphics driver and temporarily mitigate lagging.