IPC Lagging after Running for a Period of Time

You are currently viewing the documentation for the latest version (2.2.0). To access a different version, click the "Switch version" button located in the upper-right corner of the page.

■ If you are not sure which version of the product you are currently using, please feel free to contact Mech-Mind Technical Support.

Symptom:

After the IPC runs for a period of time, the whole system becomes laggy, but the planning and production workflows of Mech-Vision/Mech-Viz can still run normally.

Possible Cause:

The HAGS (Hardware-accelerated GPU scheduling) feature in Windows 11 causes system lagging.

Notes:

  1. This issue can be reproduced in software versions 2.1.2 and 2.2.0, and is not related to the software version.

  2. White-box verification confirms that there is no memory-leak issue in Mech-Vision/ Mech-Viz itself.

  3. Similar lagging behavior has also been reported for other software on Windows 11.

Solution:

  1. Disable HAGS in Windows settings.

    1. Open Settings. Press Win + I to open Windows settings.

    2. Go to display settings. In the left pane, select System, and then click Show.

    3. Open graphics settings. In the “Related Settings”, click Graphics.

    4. Change default settings. Click Change default graphics settings.

    5. Turn off HAGS. Switch the “Hardware-accelerated GPU scheduling (HAGS” to OFF.

    6. Restart the IPC. Restart the IPC to apply the settings.

  2. If lagging has already occurred, press Win + Ctrl + Shift + B to reset the graphics driver and temporarily mitigate lagging.

Is this page helpful?

You can give a feedback in any of the following ways:

We Value Your Privacy

We use cookies to provide you with the best possible experience on our website. By continuing to use the site, you acknowledge that you agree to the use of cookies. If you decline, a single cookie will be used to ensure you're not tracked or remembered when you visit this website.