Point Cloud Loss

You are currently viewing the documentation for the latest version (2.1.0). To access a different version, click the "Switch version" button located in the upper-right corner of the page.

■ If you are not sure which version of the product you are currently using, please feel free to contact Mech-Mind Technical Support.

Symptom:

Point loss occurred in point cloud in real usage scenarios.

Affected Software Versions:

All Mech-Vision versions

Possible Cause:

  • There were point losses in the point cloud output by Mech-Eye Viewer.

  • There were point losses during the point cloud processing on Mech-Vision.

Solution:

Please fix the issue according to the point cloud processing procedure. The steps are as follows:

  1. Check whether the point cloud output from Mech-Eye Viewer is up to standard.

    • If there are point clouds lost, check the parameters ROI and Height Range.

    • If no point cloud is lost, proceed to the next step.

  2. Check the processing procedure on Mech-Vision.

    1. Check whether the option Remove Background by Depth is enabled in Step “Capture Images from Camera”.

      • If yes, you should switch on the Debug Output mode, execute the single Step, and check whether the point clouds needed are removed. If they are removed, you should perform Select background depth map file again or disable Remove Background by Depth.

      • If not, proceed to the next step.

    2. Check 3D ROI.

    3. Check point clouds with the Step “Show Point Clouds and Poses”.

We Value Your Privacy

We use cookies to provide you with the best possible experience on our website. By continuing to use the site, you acknowledge that you agree to the use of cookies. If you decline, a single cookie will be used to ensure you're not tracked or remembered when you visit this website.