Communication-Related Functions
Symptom:
The communication-related functions of the Vision System are not working, primarily manifested as:
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In the toolbar of Mech-Vision, the Robot Communication Configuration button is grayed out and unusable.
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In the toolbar of Mech-Viz, the Master-Control Robot button is grayed out and unusable.
Affected Software Versions:
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Mech-Vision 1.8.0 and later versions
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Mech-Viz 1.8.0 and later versions
Possible Cause:
The communication component has not started or it crashed.
Solution:
Please address the issue by the following steps:
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Open the Task Manager of the IPC and check if there are any
python
processes running:-
If not, please execute the step 2;
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If so, terminate the processes and restart the software. If the issue still exists, please execute the step 2.
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Check if the directory path settings for the communication component are empty.
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Mech-Vision
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Mech-Viz
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In the Mech-Vision menu bar, select
, and select Developer mode. Then, click OK to enable the developer mode. -
Select
, and check if the parameter in Mech-CenterCommunication Component directory path under Communication Settings is empty.
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In the Mech-Viz menu bar, select
, and select Developer mode. Then, click OK to enable the developer mode. -
Select
, and check if the parameter in Mech-Center Communication Component directory path under Communication Settings is empty.
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If so, please execute the step 3;
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If not, find the Mmind.ini file in the
\AppData\Roaming\Mmind
directory, delete the line containing “centerDirPath”, and then restart the software to see if the issue is resolved. If the issue still exists, please execute the step 3.
-
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In the installation directory of the communication component, press shift+Right-click and open powershell. Then, type
.\python\python.exe .\src\main.py
and press Enter to verify if the communication component can start successfully.-
If it starts successfully, please confirm that the above troubleshooting steps have been completed correctly, and then contact Technical Support.
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If it does not start successfully, please troubleshoot the error based on the following link:
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If the issue cannot be resolved, please try restarting your computer and reinstalling the software. If the issue still exists, please contact Technical Support.
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