无法连接相机

您正在查看最新版本(V2.4.1)的文档。如果您想查阅其他版本的文档,可以点击页面右上角“切换版本”按钮进行切换。

■ 如果您不确定当前使用的产品是哪个版本,请随时联系梅卡曼德技术支持。

问题现象

在Mech-Eye SDK或GenICam客户端中可以搜索到需连接的相机,但无法连接该相机。

可能原因

可能导致相机无法连接的原因较多,需逐一排查:

  • 相机通过网线连接至路由器,而电脑连接的是路由器的无线网络。

  • 相机IP地址和与相机相连的电脑网口的IP地址不在同一个网段。

  • 同一局域网中有其他设备的IP地址和相机IP地址重复(即IP地址冲突)。

  • 相机的MTU值为9000,但电脑或交换机/路由器未启用或不支持巨型帧。

  • 电脑上多个网口的IP地址在同一网段。

解决方案

本节内容仅适用于Windows系统。如果你使用的是Ubuntu系统,请联系技术支持。

请按照以下小节逐一排查上述可能原因。

电脑连接至路由器无线网络

请执行以下步骤排查问题:

  1. 打开控制面板,选择网络和Internet下的查看网络状态和任务

  2. 确认连接处是否显示WLAN

    • 如是,请执行步骤3。

    • 如否,请查看下一小节。

  3. 禁用路由器的无线网络功能,或使用网线连接路由器和电脑。然后,在Mech-Eye SDK或GenICam客户端中确认是否能连接相机。

    • 如是,故障排查结束。

    • 如否,请查看下一小节。

相机IP地址和电脑网口的IP地址不在同一个网段

请执行以下步骤排查问题:

  1. 在Mech-Eye Viewer中确认相机的IP地址。

  2. 参考设置电脑IP地址,查看电脑上与该相机相连的电脑网口的IP地址。

    • 如电脑网口设置为自动获得IP地址,请参考设置电脑IP地址为网口设置静态IP地址。然后,执行步骤3。

    • 如两个IP地址不在同一网段,请修改相机或电脑网口的IP地址,使两者位于在同一网段。然后,执行步骤3。

      修改相机的IP地址

      使用Mech-Eye ViewerIP配置工具修改。

      修改电脑网口的IP地址

      请参考设置电脑IP地址

    • 如两个IP地址在同一网段,请查看下一小节。

  3. 在Mech-Eye SDK或GenICam客户端中确认是否能连接相机。

    • 如是,故障排查结束。

    • 如否,请查看下一小节。

IP地址冲突

请执行以下步骤排查问题:

  1. 断开电脑与相机以外设备的连接,包括通过交换机/路由器连接的设备。

  2. 在Mech-Eye SDK或GenICam客户端中确认是否能连接相机。

    • 如是,则有其他设备IP地址与相机相同,请执行步骤3。

    • 如否,请查看下一小节。

  3. 将其中一个设备连接至电脑,然后在Mech-Eye SDK或GenICam客户端中确认是否能连接相机。确认后,断开该设备的连接。重复此过程,直至找到连接后导致相机无法连接的设备。该设备即和相机拥有相同的IP地址。

  4. 更改该设备的IP地址,或使用Mech-Eye ViewerIP配置工具更改相机的IP地址。然后,将其余设备重新连接至电脑。

  5. 在Mech-Eye SDK或GenICam客户端中再次确认是否能连接相机。

    • 如是,故障排查结束。

    • 如否,请查看下一小节。

未启用或不支持巨型帧

如未将相机的MTU值修改为9000,请跳过此节。
  1. 确认电脑是否已启用了巨型帧。详见启用巨型帧

    • 如是,请执行步骤2。

    • 如否,请启用巨型帧后,在Mech-Eye SDK或GenICam客户端中确认是否能连接相机。

      • 如是,故障排查结束。

      • 如否,请执行步骤2。

  2. 如使用了交换机/路由器连接电脑和相机,请执行步骤3。如电脑和相机直接连接,请执行步骤4。

  3. 根据交换机/路由器的说明书或联系生产厂商确认该设备是否支持巨型帧。

    • 如支持,请根据交换机/路由器的说明书开启巨型帧。然后,在Mech-Eye SDK或GenICam客户端中确认是否能连接相机。

      • 如是,故障排查结束。

      • 如否,请执行步骤4。

        如条件允许,可更换为支持巨型帧的交换机/路由器。
    • 如不支持,请执行步骤4。

  4. 相机的MTU值修改为1500。然后,在Mech-Eye SDK或GenICam客户端中确认是否能连接相机。

    • 如是,故障排查结束。

    • 如否,请查看下一小节。

电脑上多个网口的IP地址在同一网段

请执行以下步骤排查问题:

  1. 禁用电脑上连接相机以外设备的网口:

    1. 打开控制面板,选择网络和Internet下的查看网络状态和任务

    2. 选择左边栏的更改适配器设置,将弹出网络连接窗口。

    3. 网络连接窗口中,依次右键单击连接相机以外设备的网口,选择禁用

  2. 在Mech-Eye SDK或GenICam客户端中确认是否能连接相机。

    • 如是,则电脑上有多个网口的IP地址在同一网段,请执行步骤3。

    • 如否,请执行步骤4。

  3. 更改禁用网口的IP地址并重新启用这些网口:

    1. 回到网络连接窗口,参考设置电脑IP地址,将禁用网口的IP地址设置至其他网段。

    2. 右键单击这些网口,选择启用,重新启用这些网口。然后,在Mech-Eye SDK或GenICam客户端中再次确认是否能连接相机。

      • 如是,故障排查结束。

      • 如否,请执行步骤4。

  4. 重启相机:断开相机的电源,然后重新连接。然后,在Mech-Eye SDK或GenICam客户端中再次确认是否能连接相机。

    • 如是,故障排查结束。

    • 如否,请联系技术支持。

我们重视您的隐私

我们使用 cookie 为您在我们的网站上提供最佳体验。继续使用该网站即表示您同意使用 cookie。如果您拒绝,将使用一个单独的 cookie 来确保您在访问本网站时不会被跟踪或记住。