数据采集时间过长

您正在查看最新版本(V2.4.1)的文档。如果您想查阅其他版本的文档,可以点击页面右上角“切换版本”按钮进行切换。

■ 如果您不确定当前使用的产品是哪个版本,请随时联系梅卡曼德技术支持。

问题现象

通过Mech-Eye SDK控制相机采集数据后,数据采集时间远超正常采集时间。使用Mech-Eye Viewer连接相机并查看左上角的数据传输速度,发现传输速度低于700Mbps(NANO和PRO XS低于500Mbps)。

可能原因

  • 所用交换机、路由器、网卡或网线不支持千兆带宽。

  • 相机网线连接、敷设不正确或需更换。

  • 相机的MTU值为9000,但电脑或交换机/路由器未启用或不支持巨型帧。

  • 电脑网口的驱动需更新或网口设置有误。

解决方案

请执行以下步骤排查问题:

  1. 确认所用的交换机、路由器、网卡或网线是否支持千兆带宽。

    • 如不支持,请更换为支持千兆带宽的交换机、路由器、网卡或网线。百兆带宽无法保证数据传输的稳定性。更换后,请确认问题现象是否仍存在。

      • 如不存在,故障排查结束。

      • 如仍存在,请执行步骤2。

    • 如支持,请执行步骤2。

  2. 检查相机网线是否有磨损、断裂等问题。

    • 如有此类问题,请联系技术支持更换相机网线。然后,请确认问题现象是否仍存在。

      • 如不存在,故障排查结束。

      • 如仍存在,请执行步骤3。

    • 如无此类问题,请执行步骤3。

  3. 参考相机硬件用户手册相机线缆敷设规范,检查相机网线是否正确连接和敷设,没有插头紧固螺母未拧紧、与其他线缆缠绕等问题。

    • 如相机网线未正确连接和敷设,请更正后确认问题现象是否仍存在。

      • 如不存在,故障排查结束。

      • 如仍存在,请执行步骤4。

    • 如相机网线已正确连接和敷设,请执行步骤4。

  4. 确认是否曾将相机的MTU值修改为9000。

    • 如是,请执行步骤5。

    • 如否,请执行步骤9。

  5. 确认电脑是否已启用了巨型帧。详见启用巨型帧

    • 如是,请执行步骤6。

    • 如否,请启用巨型帧后,在Mech-Eye SDK或GenICam客户端中确认是否能连接相机。

      • 如是,故障排查结束。

      • 如否,请执行步骤6。

  6. 如使用了交换机/路由器连接电脑和相机,请执行步骤7。如电脑和相机直接连接,请执行步骤8。

  7. 根据交换机/路由器的说明书或联系生产厂商确认该设备是否支持巨型帧。

    • 如支持,请根据交换机/路由器的说明书开启巨型帧。然后,在Mech-Eye SDK或GenICam客户端中确认是否能连接相机。

      • 如是,故障排查结束。

      • 如否,请执行步骤8。

        如条件允许,可更换为支持巨型帧的交换机/路由器。
    • 如不支持,请执行步骤8。

  8. 相机的MTU值修改为1500。然后,在Mech-Eye SDK或GenICam客户端中确认是否能连接相机。

    • 如是,故障排查结束。

    • 如否,请执行步骤9。

  9. 检查电脑上与相机相连的网口,确认其驱动是否需要更新,或其设置是否需要更改(例如,可能需要取消传输速度限制)。

    • 如需要,请更新驱动或更改设置后确认问题现象是否仍存在。

      • 如不存在,故障排查结束。

      • 如仍存在,请执行步骤5。

    • 如不需要,请执行步骤5。

  10. 尝试更换与相机相连的网口,为该网口设置与其他网口不同的网段,或禁用其他未使用的网口。然后,请确认问题现象是否仍存在。

    • 如不存在,故障排查结束。

    • 如仍存在,请联系技术支持。

以下问题可能由相同的原因导致。如同时遇到这些问题,在解决本章涉及的问题后,可确认其他问题是否也已解决。

数据采集速度正常时,如需进一步缩短采集时间,可参考提高数据采集速度章节。

我们重视您的隐私

我们使用 cookie 为您在我们的网站上提供最佳体验。继续使用该网站即表示您同意使用 cookie。如果您拒绝,将使用一个单独的 cookie 来确保您在访问本网站时不会被跟踪或记住。