Luminosité non uniforme dans l’image 2D
Symptôme
Lors de l’utilisation de l'Intrinsic Parameter Tool pour vérifier les paramètres intrinsèques dans Mech-Eye Viewer, la boîte de message dans la partie inférieure de l’interface logicielle indiquait que la luminosité de l’image 2D est non uniforme, ce qui ne répond pas aux exigences de l’image.
Causes possibles
-
Le paramètre Mode d’exposition dans la catégorie Paramètres 2D était réglé sur Flash. De plus, certaines zones des cercles sur la plaque d’étalonnage étaient en dehors de la plage d’éclairage d’appoint, entraînant une luminosité non uniforme de certains cercles d’étalonnage.
-
Il y avait des objets dans l’environnement qui bloquaient une partie de la source lumineuse, provoquant l’apparition d’ombres sur la plaque d’étalonnage.
-
La surface de la plaque d’étalonnage présentait des rayures importantes ou des taches visibles, ce qui affectait la détection des cercles d’étalonnage.
Solutions
Suivez ces étapes pour résoudre le problème:
-
Si le Mode d’exposition est réglé sur Flash, ajustez la position de la plaque d’étalonnage afin de garantir que l’ensemble de la plaque se trouve dans la plage d’éclairage d’appoint de la caméra.
-
Après avoir ajusté la position, vérifiez à nouveau les paramètres intrinsèques et confirmez si ce message apparaît.
-
S’il n’apparaît pas, le dépannage est terminé.
-
Si le message apparaît, réglez le Mode d’exposition sur Temporisé ou Auto, ajustez les paramètres d’exposition, et vérifiez à nouveau le paramètre intrinsèque. Si le message apparaît toujours, passez à l’étape 2.
-
-
-
S’il y a des objets dans l’environnement qui bloquent la source lumineuse, ajustez la position de la caméra ou de la plaque d’étalonnage pour éviter que la source lumineuse ne soit occultée.
-
Après avoir ajusté la position, vérifiez à nouveau les paramètres intrinsèques et confirmez si ce message apparaît.
-
S’il n’apparaît pas, le dépannage est terminé.
-
Si le message apparaît, éteignez ou ajustez l’éclairage supérieur et les autres sources lumineuses, puis vérifiez à nouveau les paramètres intrinsèques. Si le message apparaît toujours, passez à l’étape 3.
-
-
-
Vérifiez si la surface de la plaque d’étalonnage est intacte. S’il existe des taches visibles, nettoyez la plaque d’étalonnage, en particulier les zones des cercles d’étalonnage. S’il y a de profondes rayures, il est recommandé de remplacer la plaque d’étalonnage.
-
Après cela, vérifiez à nouveau les paramètres intrinsèques et confirmez si ce message apparaît.
-
S’il n’apparaît pas, le dépannage est terminé.
-
Si le message apparaît, passez à la section suivante.
-
-
Solutions alternatives
Si aucune des solutions ci-dessus ne résout le problème, il est recommandé de contacter le Support technique. Si vous souhaitez continuer le dépannage, reportez-vous aux solutions suivantes pour ajuster les paramètres d’exposition, ajuster l’éclairage ou repositionner la plaque d’étalonnage.
Ajuster les paramètres d’exposition
-
Si l’image 2D est surexposée ou sous-exposée dans certaines zones, réglez le Mode d’exposition sur HDR.
-
Après avoir ajusté le paramètre, vérifiez à nouveau les paramètres intrinsèques et confirmez si ce message apparaît.
-
S’il n’apparaît pas, le dépannage est terminé.
-
Si le message apparaît toujours, passez à l’étape 2.
-
-
-
Ajustez le temps d’exposition ou le gain afin d’assurer une lumière uniforme sur la plaque d’étalonnage.
-
Après avoir ajusté le paramètre, vérifiez à nouveau les paramètres intrinsèques et confirmez si ce message apparaît.
-
S’il n’apparaît pas, le dépannage est terminé.
-
Si le message apparaît, vérifiez le modèle de caméra que vous utilisez.
Si vous utilisez DEEP-GL, LSR S-GL, LSR L-GL ou LSR XL-GL, passez à l’étape 3.
Si vous utilisez un autre modèle, passez à la section suivante.
-
-
-
Réglez le Mode d’exposition sur Temporisé ou Auto, et ajustez les paramètres d’exposition afin de garantir une projection uniforme de la ligne laser.
-
Après avoir ajusté le paramètre, vérifiez à nouveau les paramètres intrinsèques et confirmez si ce message apparaît.
-
S’il n’apparaît pas, le dépannage est terminé.
-
Si le message apparaît, ajustez la puissance du laser puis vérifiez à nouveau les paramètres intrinsèques. Si le message apparaît toujours, passez à la section suivante.
-
-
Ajuster l’éclairage externe
-
Si vous utilisez une source lumineuse ponctuelle (comme une LED unique), utilisez une source lumineuse diffuse (comme un rideau lumineux ou un éclairage annulaire), ou augmentez le nombre de sources lumineuses et ajustez leur disposition afin d’assurer une couverture lumineuse uniforme sur la plaque d’étalonnage.
-
Après cela, vérifiez à nouveau les paramètres intrinsèques et confirmez si ce message apparaît.
-
S’il n’apparaît pas, le dépannage est terminé.
-
Si le message apparaît, passez à la section suivante.
-
-
Repositionner les objets autour de la plaque d’étalonnage
-
S’il y a des objets réfléchissants près de la plaque d’étalonnage, couvrez l’objet pour éviter une luminosité anormale dans certaines zones de la plaque.
-
Après cela, vérifiez à nouveau les paramètres intrinsèques et confirmez si ce message apparaît.
-
S’il n’apparaît pas, le dépannage est terminé.
-
Si le message apparaît, veuillez contacter le Support technique.
-
-