La caméra n’a pas projeté de lumière, et la carte de profondeur n’a pas été générée
Symptôme
Après avoir commandé la caméra pour acquérir des images avec Mech-Eye SDK, la caméra n’a pas projeté de lumière, et le logiciel n’a pas reçu la carte de profondeur.
-
Mech-Eye Viewer: L’interface d’affichage de la carte de profondeur n’a affiché que l’image suivante.
-
Mech-Eye API: Après l’appel de la méthode d’acquisition d’image, le code d’erreur -6 a été renvoyé.
-
Client GenICam: Une erreur de dépassement de délai a pu se produire.
Causes possibles
-
Les câbles de la caméra ne sont pas correctement connectés.
-
Le câble d’alimentation DC de l’alimentation sur rail DIN est trop long.
-
La tension de l’alimentation est insuffisante.
Solution
| Les instructions de cette section sont uniquement applicables au système d’exploitation Windows. Si vous utilisez le système d’exploitation Ubuntu, veuillez contacter le support technique. |
-
En fonction de l’heure à laquelle le problème est survenu, dans Mech-Eye Viewer, ouvrez le dernier journal généré avant que le problème ne survienne.
-
Dans ce journal, en vous basant sur l’heure à gauche, trouvez le message enregistré lorsque le problème est survenu. En fonction du code d’erreur dans le message, consultez la solution correspondante ci-dessous.
Code d’erreur 0x0105, 0x0107 ou 0x0109
Veuillez suivre ces étapes pour résoudre le problème :
-
Reportez-vous au Manuel du matériel de la caméra et au Consignes de montage des câbles de la caméra et vérifiez si les câbles de la caméra sont correctement connectés et montés, sans problèmes tels qu’un écrou de connecteur pas complètement serré ou un enchevêtrement avec d’autres câbles.
-
Si les câbles de la caméra ne sont pas correctement connectés et montés, veuillez corriger la connexion et le montage, puis vérifiez si les symptômes sont toujours présents.
-
S’ils ne sont pas présents, le dépannage est terminé.
-
S’ils sont toujours présents, passez à l’étape 2.
-
-
Si les câbles de la caméra sont correctement connectés et montés, passez à l’étape 2.
-
-
En fonction de l’alimentation de la caméra, passez à l’étape correspondante :
-
Si une alimentation sur rail DIN ou un adaptateur secteur est utilisé pour alimenter la caméra, passez à l’étape 3.
-
Si un véhicule à guidage automatique (AGV) est utilisé pour alimenter la caméra, passez à l’étape 4.
-
-
Vérifiez si l’alimentation est correctement mise à la terre : si une alimentation sur rail DIN est utilisée pour alimenter la caméra, reportez-vous au Manuel du matériel de la caméra pour vérifier si le fil PE de l’alimentation sur rail DIN est correctement connecté. Si un adaptateur secteur est utilisé pour alimenter la caméra, vérifiez si la prise d’alimentation à laquelle est connecté le connecteur à 3 broches du câble d’alimentation AC de l’adaptateur est correctement mise à la terre.
-
Si l’alimentation n’est pas correctement mise à la terre, corrigez la mise à la terre, puis vérifiez si les symptômes sont toujours présents.
-
S’ils ne sont pas présents, le dépannage est terminé.
-
S’ils sont toujours présents, veuillez contacter le support technique.
-
-
Si l’alimentation est correctement mise à la terre mais que le symptôme est toujours présent, veuillez contacter le support technique.
-
-
Vérifiez si un relais temporisé est utilisé sur l’AGV pour assurer une tension stable.
-
Si aucun relais temporisé n’est utilisé, veuillez en ajouter un puis vérifiez si les symptômes sont toujours présents.
-
S’ils ne sont pas présents, le dépannage est terminé.
-
S’ils sont toujours présents, veuillez contacter le support technique.
-
-
Si un relais temporisé est déjà utilisé, veuillez contacter le support technique.
-
Code d’erreur 0x020c
Veuillez suivre ces étapes pour résoudre le problème :
Vérifiez si le câble d’alimentation DC de l’alimentation sur rail DIN dépasse 20 m.
-
Si le câble dépasse 20 m, veuillez ajuster la tension de l’alimentation sur rail DIN de sorte que la tension fournie à la caméra soit augmentée de 2 V.
-
Si le câble ne dépasse pas 20 m, veuillez contacter le support technique.
Problèmes connexes
Les problèmes suivants peuvent être dus aux mêmes causes. Si vous avez également rencontré ces problèmes, après avoir résolu le problème dans ce sujet, vous pouvez vérifier si ces autres problèmes ont également été résolus.