Temps d’acquisition des données trop long
Symptôme
Après avoir commandé la caméra pour acquérir des données avec Mech-Eye SDK, le temps d’acquisition des données était nettement plus long que la normale. Lors de l’utilisation de Mech-Eye Viewer pour se connecter à la caméra et vérifier la vitesse de transmission des données dans le coin supérieur gauche de l’interface, la vitesse de transmission des données était plus lente que 700 Mbps (plus lente que 500 Mbps pour NANO-GL).
Causes possibles
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Le commutateur réseau, le routeur, la carte d’interface réseau ou les câbles Ethernet utilisés ne prennent pas en charge une bande passante gigabit.
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Le câble Ethernet de la caméra n’est pas correctement connecté ou monté, ou le câble doit être remplacé.
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La taille MTU du Caméra est de 9000, mais l’ordinateur ou le commutateur / routeur réseau n’a pas activé les trames jumbo ou ne les prend pas en charge.
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Le pilote du port Ethernet de l’ordinateur nécessite une mise à jour ou les paramètres du port Ethernet sont incorrects.
Solution
Veuillez suivre ces étapes pour résoudre le problème :
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Vérifiez si le commutateur réseau, le routeur, la carte d’interface réseau ou les câbles Ethernet utilisés prennent en charge une bande passante gigabit.
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Si la bande passante gigabit n’est pas prise en charge, remplacez le commutateur réseau, le routeur, la carte d’interface réseau ou les câbles Ethernet par des modèles qui prennent en charge la bande passante gigabit. Une bande passante mégabit ne peut pas garantir la stabilité de la transmission des données. Après le remplacement de l’équipement, vérifiez si les symptômes sont toujours présents.
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Si les symptômes ne sont pas présents, le dépannage est terminé.
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Si les symptômes sont toujours présents, passez à l’étape 2.
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Si la bande passante gigabit est prise en charge, passez à l’étape 2.
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Vérifiez si le câble Ethernet de la caméra est usé, cassé ou autrement endommagé.
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Si le câble Ethernet de la caméra est endommagé, contactez le support technique pour obtenir un remplacement. Ensuite, vérifiez si les symptômes sont toujours présents.
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Si les symptômes ne sont pas présents, le dépannage est terminé.
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Si les symptômes sont toujours présents, passez à l’étape 3.
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Si le câble Ethernet de la caméra n’est pas endommagé, passez à l’étape 3.
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Reportez-vous au Manuel du matériel de la caméra et au Consignes de montage des câbles de caméra et vérifiez si le câble Ethernet de la caméra est correctement connecté et monté, sans problèmes tels qu’un écrou de connecteur pas entièrement serré ou un enchevêtrement avec d’autres câbles.
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Si le câble Ethernet de la caméra n’est pas correctement connecté et monté, corrigez la connexion et le montage, puis vérifiez si les symptômes sont toujours présents.
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Si les symptômes ne sont pas présents, le dépannage est terminé.
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Si les symptômes sont toujours présents, passez à l’étape 4.
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Si le câble Ethernet de la caméra est correctement connecté et monté, passez à l’étape 4.
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Vérifiez si la Taille MTU du Caméra a été modifiée à 9000.
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Si oui, passez à l’étape 5.
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Si non, passez à l’étape 9.
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Vérifiez si l’ordinateur a activé les trames jumbo. Pour plus de détails, reportez-vous à Activer les trames jumbo.
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Si oui, passez à l’étape 6.
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Si non, activez les trames jumbo, puis vérifiez si le Caméra peut être connecté dans Mech-Eye SDK ou le client GenICam.
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Si oui, le dépannage est terminé.
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Si non, passez à l’étape 6.
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Si le Caméra est connecté à l’ordinateur via un commutateur / routeur réseau, passez à l’étape 7. Si le Caméra est connecté directement à l’ordinateur, passez à l’étape 8.
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Reportez-vous au manuel d’utilisation du commutateur / routeur réseau ou contactez le fabricant pour vérifier si l’appareil prend en charge les trames jumbo.
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Si l’appareil prend en charge les trames jumbo, activez la fonction conformément au manuel d’utilisation du commutateur / routeur réseau. Ensuite, vérifiez si le Caméra peut être connecté dans Mech-Eye SDK ou le client GenICam.
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Si oui, le dépannage est terminé.
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Si non, passez à l’étape 8.
Si possible, vous pouvez remplacer le commutateur / routeur réseau par un modèle qui prend en charge les trames jumbo.
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Si l’appareil ne prend pas en charge les trames jumbo, passez à l’étape 8.
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Modifiez la Taille MTU du Caméra à 1500. Ensuite, vérifiez si le Caméra peut être connecté dans Mech-Eye SDK ou le client GenICam.
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Si oui, le dépannage est terminé.
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Si non, passez à l’étape 9.
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Vérifiez le port Ethernet de l’ordinateur connecté à la caméra et voyez si son pilote nécessite une mise à jour ou si ses paramètres nécessitent une modification (par exemple, une limitation de vitesse sur la transmission des données peut devoir être levée).
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Si une mise à jour du pilote ou une modification des paramètres est requise, effectuez-la, puis vérifiez si les symptômes sont toujours présents.
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Si les symptômes ne sont pas présents, le dépannage est terminé.
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Si les symptômes sont toujours présents, passez à l’étape 5.
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Si une mise à jour du pilote ou une modification des paramètres n’est pas requise, passez à l’étape 5.
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Essayez d’utiliser un autre port Ethernet de l’ordinateur pour connecter la caméra, définir l’adresse IP du port Ethernet de l’ordinateur sur un sous-réseau unique non utilisé par d’autres ports, ou désactiver les autres ports Ethernet de l’ordinateur qui ne sont pas utilisés. Ensuite, vérifiez si les symptômes sont toujours présents.
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Si les symptômes ne sont pas présents, le dépannage est terminé.
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Si les symptômes sont toujours présents, veuillez contacter le support technique.
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Problèmes connexes
Les problèmes suivants peuvent avoir les mêmes causes. Si vous avez également rencontré ces problèmes, après avoir résolu le problème décrit dans ce sujet, vous pouvez vérifier si ces autres problèmes ont également été résolus.
Pour augmenter davantage la vitesse d’acquisition lorsque celle-ci se situe dans la plage normale, reportez-vous à Augmenter la vitesse d’acquisition des données.