搜索不到相机
问题现象
在Mech-Eye SDK或GenICam客户端中无法搜索到需连接的相机。
如为首次使用相机,且在Mech-Eye SDK或GenICam客户端中无法搜索到该相机,请参考相机首次使用时无法搜索到。 |
可能原因
可能导致相机无法搜索到的原因较多,需逐一排查:
-
相机线缆连接、敷设不正确或需更换。
-
相机通过网线连接至路由器,而电脑连接的是路由器的无线网络。
-
Windows系统防火墙或杀毒软件拦截了软件与相机的通信。
-
Mech-Eye API或GenICam客户端:相机IP地址和与相机相连的电脑网口的IP地址不在同一个网段。
-
电脑上多个网口的IP地址在同一网段。
解决方案
本节需在电脑上操作的内容仅适用于Windows系统。如果你使用的是Ubuntu系统,请联系技术支持。 |
请按照以下小节逐一排查上述可能原因。
电脑连接至路由器无线网络
请执行以下步骤排查问题:
-
打开控制面板,选择网络和Internet下的查看网络状态和任务。
-
确认连接处是否显示WLAN。
-
如是,请执行步骤3。
-
如否,请查看下一小节。
-
-
禁用路由器的无线网络功能,或使用网线连接路由器和电脑。然后,在Mech-Eye SDK或GenICam客户端中确认是否能搜索到相机。
-
如是,故障排查结束。
-
如否,请查看下一小节。
-
通信被拦截
请执行以下步骤排查问题:
-
打开控制面板,选择
。 -
选择左边栏的启用或关闭Windows Defender防火墙,然后确认选中的选项。
-
如选中的选项是启用Windows Defender防火墙,请改为关闭Windows Defender防火墙。然后,在Mech-Eye SDK或GenICam客户端中确认是否能搜索到相机。
-
如是,故障排查结束。
-
如否,请执行步骤3。
-
-
如选中的选项是关闭Windows Defender防火墙,请执行步骤3。
-
-
关闭电脑上安装的杀毒软件,或修改其中的拦截设置,允许Mech-Eye Viewer或GenICam客户端的通信。然后,在Mech-Eye SDK或GenICam客户端中确认是否能搜索到相机。
-
如是,故障排查结束。
-
如否,请查看下一小节。
-
相机IP地址和电脑网口的IP地址不在同一个网段
此节仅适用于Mech-Eye API或GenICam客户端。 |
请执行以下步骤排查问题:
-
在Mech-Eye Viewer中确认相机的IP地址。
-
参考设置电脑IP地址,查看电脑上与该相机相连的电脑网口的IP地址。
-
如电脑网口设置为自动获得IP地址,请参考设置电脑IP地址为网口设置静态IP地址。然后,执行步骤3。
-
如两个IP地址不在同一网段,请修改相机或电脑网口的IP地址,使两者位于在同一网段。然后,执行步骤3。
修改相机的IP地址
使用Mech-Eye Viewer或IP配置工具修改。
修改电脑网口的IP地址
请参考设置电脑IP地址。
-
如两个IP地址在同一网段,请查看下一小节。
-
-
在Mech-Eye API或GenICam客户端中确认是否能搜索到相机。
-
如是,故障排查结束。
-
如否,请查看下一小节。
-
电脑上多个网口的IP地址在同一网段
请执行以下步骤排查问题:
-
禁用电脑上连接相机以外设备的网口:
-
打开控制面板,选择网络和Internet下的查看网络状态和任务。
-
选择左边栏的更改适配器设置,将弹出网络连接窗口。
-
在网络连接窗口中,依次右键单击连接相机以外设备的网口,选择禁用。
-
-
在Mech-Eye SDK或GenICam客户端中确认是否能搜索到相机。
-
如是,则电脑上有多个网口的IP地址在同一网段,请执行步骤3。
-
如否,请执行步骤4。
-
-
更改禁用网口的IP地址并重新启用这些网口:
-
回到网络连接窗口,参考设置电脑IP地址,将禁用网口的IP地址设置至其他网段。
-
右键单击这些网口,选择启用,重新启用这些网口。然后,在Mech-Eye SDK或GenICam客户端中再次确认是否能搜索到相机。
-
如是,故障排查结束。
-
如否,请执行步骤4。
-
-
-
重启相机:断开相机的电源,然后重新连接。然后,在Mech-Eye SDK或GenICam客户端中再次确认是否能搜索到相机。
-
如是,故障排查结束。
-
如否,请联系技术支持。
-