カメラを検索できない

現在ご覧いただいているのは最新版の内容です(V2.4.0)。異なるバージョンを参照する場合は、画面右上のボタンから切り替えが可能です。

■ ご利用中のバージョンが分からない場合はお気軽にサポート窓口までご連絡ください。

問題

Mech-Eye SDK または GenICam 対応ソフトウェアでは使用するカメラを検索できません。

注記: 初めてカメラをご使用になり、Mech-Eye SDK または GenICam 対応ソフトウェアではカメラを検索できない場合、初めてカメラを使用する時に検索できないをお読みください。

考えられる原因

カメラが接続できない原因はいくつかあります。

  • カメラケーブルが正しく接続または配線されていないか、交換が必要になります。

  • カメラは LAN ケーブルでルーターに接続されていますがコンピュータはルーターのワイヤレスネットワークに接続されています。

  • Windows システムファイアウォールまたはウイルス対策ソフトがソフトウェアとカメラとの通信を遮断しました。

  • Mech-Eye APIまたは GenICam 対応ソフトウェア:カメラ IP アドレスとカメラに接続されているコンピュータの LAN ポートの IP アドレスが同じネットワークセグメントにありません。

  • コンピュータの複数の LAN ポートの IP アドレスが同じネットワークセグメントにあります。

解決策

重要: 本節の説明は、コンピュータでの操作に関する内容は Windows オペレーティングシステムにのみ使用できます。Ubuntu オペレーティングシステムを使用する場合、テクニカルサポートにお問い合わせください。

以下の指示に従ってトラブルシューティングを実行してください。

ケーブルが正しく接続または配線されていないか、交換が必要になる場合

以下の手順でトラブルシューティングを実行してください。

  1. カメラケーブルの断線や損傷があるか確認します。

    • ある場合、テクニカルサポートに連絡してカメラケーブルを交換してください。それ Mech-Eye SDK または GenICam 対応ソフトウェアでカメラを検索できるか確認します。

      • 検索できる場合は、トラブルシューティングは終了です。

      • 検索できない場合は手順 2 に入ります。

    • このような問題がない場合、手順 2 を実行してください。

  2. カメラ取扱説明書カメラケーブルの配線規範に従って、カメラケーブルの接続が正しいかどうか、プラグがしっかり締まっているか、他のケーブルと絡まっていないかなどを確認します。

    • カメラケーブルが正しく接続および配線されていない場合は、修正してから再度 Mech-Eye SDK または GenICam 対応ソフトウェアでカメラを検索できるかを確認します。

      • 検索できる場合は、トラブルシューティングは終了です。

      • 検索できない場合は次の部分に入ります。

    • カメラケーブルが正しく接続および配線されている場合は、次の部分に入ります。

コンピュータがルーターのワイヤレスネットワークに接続されている場合

以下の手順でトラブルシューティングを実行してください。

  1. コントロールパネルを開き、ネットワークとインターネットネットワークの状態とタスクの表示を選択します。

  2. ネットワーク接続には Wi-Fi が表示されているか確認します。

    • 表示されている場合は手順 3 に入ります。

    • 検索できない場合は次の部分に入ります。

  3. ルーターのワイヤレスネットワークを無効にするか、LAN ケーブルを使用してルーターとコンピュータを接続します。それ Mech-Eye SDK または GenICam 対応ソフトウェアでカメラを検索できるか確認します。

    • 検索できる場合は、トラブルシューティングは終了です。

    • 検索できない場合は次の部分に入ります。

通信が遮断された場合

以下の手順でトラブルシューティングを実行してください。

  1. コントロールパネルシステムとセキュリティ  Windows Defender ファイアウォール詳細設定を順番にクリックします。

  2. Windows Defender ファイアウォールの有効化または無効化を選択して以下のように確認します。

    • Windows Defender ファイアウォールの有効化がチェックされた場合、Windows Defender ファイアウォールの無効化をチェックします。それ Mech-Eye SDK または GenICam 対応ソフトウェアでカメラを検索できるか確認します。

      • 検索できる場合は、トラブルシューティングは終了です。

      • 検索できない場合は手順 3 に入ります。

    • Windows Defender ファイアウォールの無効化がチェックされた場合、手順 3 を実行します。

  3. コンピュータで実行しているウイルス対策ソフトを終了するか遮断設定を変更して Mech-Eye Viewer または GenICam 対応ソフトウェアへの通信を許可します。それ Mech-Eye SDK または GenICam 対応ソフトウェアでカメラを検索できるか確認します。

    • 検索できる場合は、トラブルシューティングは終了です。

    • 検索できない場合は次の部分に入ります。

カメラの IP アドレスとコンピュータの LAN ポートの IP アドレスが同じネットワークセグメントにない場合

注記: ここの内容は Mech-Eye API と GenICam 対応ソフトウェアにのみ使用できます。

以下の手順でトラブルシューティングを実行してください。

  1. Mech-Eye Viewer でカメラの IP アドレスを確認します。

  2. コンピュータの IP アドレスを設定するを参照してカメラに接続されているコンピュータの LAN ポートの IP アドレスを確認します。

    • コンピュータの LAN ポートは IP アドレスを自動的に取得するに設定された場合、コンピュータの IP アドレスを設定するを参照して LAN ポートに静的 IP アドレスを設定してください。それから手順 3 に進みます。

    • 2つの IP アドレスが異なるネットワークセグメントにある場合、カメラまたはコンピュータの IP アドレスを変更して同じネットワークセグメントに設定してください。それから手順 3 に進みます。

      カメラの IP アドレスを変更する

      Mech-Eye Viewerまたは IP 設定ツールを使用して変更します。

      コンピュータのネットワークポートの IP アドレスを変更する

      詳細については、コンピュータの IP アドレスを設定する をご参照ください

    • 2つの IP アドレスが同じネットワークセグメントにある場合は次の内容に進みます。

  3. Mech-Eye APIまたは GenICam 対応ソフトウェアでカメラを検索できるか確認します。

    • 検索できる場合は、トラブルシューティングは終了です。

    • 検索できない場合は次の部分に入ります。

コンピュータの複数の LAN ポートの IP アドレスが同じネットワークセグメントにある場合

以下の手順でトラブルシューティングを実行してください。

  1. カメラ以外のデバイスに接続されたコンピュータの LAN ポートを無効にします。

    1. コントロールパネルを開き、ネットワークとインターネットネットワークの状態とタスクの表示を選択します。

    2. アダプターの設定の変更をクリックし、ネットワーク接続ウィンドウが表示されます。

    3. ネットワーク接続ウィンドウで、カメラ以外のデバイスに接続された LAN ポートを右クリックして無効にするをクリックします。

  2. それでMech-Eye SDKまたは GenICam 対応ソフトウェアでカメラを検索できるか確認します。

    • 検索できる場合、コンピュータの複数の LAN ポートが同じネットワークセグメントにあります。手順 3 を実行します。

    • 検索できない場合は手順 4 に入ります。

  3. 無効にした LAN ポートの IP アドレスを変更してからまた有効にします。

    1. ネットワーク接続ウィンドウでコンピュータの IP アドレスを設定するを参照して無効にした LAN ポートの IP アドレスを他のネットワークセグメントに設定します。

    2. これらの LAN ポートを右クリックして有効にするをクリックします。それでMech-Eye SDKまたは GenICam 対応ソフトウェアでカメラを接続できるか確認します。

      • 検索できる場合は、トラブルシューティングは終了です。

      • 検索できない場合は手順 4 に入ります。

  4. カメラを再起動:カメラの電源を切断してから入れます。それでMech-Eye SDKまたは GenICam 対応ソフトウェアでカメラを接続できるか確認します。

    • 検索できる場合は、トラブルシューティングは終了です。

    • 検索できない場合は、テクニカルサポートにお問い合わせください。

Mech-Mindは、お客様のプライバシーを重視しています

このサイトでは最高の体験を提供するために Cookie を使用しています。サイトの閲覧を続ける場合、Cookie の使用に同意したことになります。「拒否する」を選択すると、このサイトを訪れた際に追跡や記憶が行われないように単独の Cookie が使用されます。