Camera Used for the First Time Could Not Be Discovered

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Symptom

The camera was produced between October of 2022 and March of 2023, and the hardware version is A3; when this camera was used for the first time, it could not be discovered by Mech-Eye SDK or the GenICam client.

You can determine the production year and month and the hardware version of the camera from the serial number.

Possible Causes

The camera was set to have its IP address dynamically assigned in the factory.

Solutions

Please follow these steps to troubleshoot the issue:

  1. Connect the camera and computer through a router. The router can dynamically assign an IP address to the camera, so that it can be discovered by Mech-Eye SDK or the GenICam client.

  2. Set a static IP address for the camera with Mech-Eye Viewer or the IP configuration tool.

  3. Restart the camera: Disconnect the camera from power and then reconnect it to power.

  4. Remove the router and restore the original way of connecting the camera and computer. Then, check if the camera could be discovered by Mech-Eye SDK and the GenICam client.

    • If so, the troubleshooting is completed.

    • If not, please contact Technical Support.

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