Only One of Multiple Cameras Could Be Discovered

Symptom

Multiple cameras are connected to the computer, but only one of the cameras could be discovered by Mech-Eye SDK or the GenICam client.

Possible Causes

The camera IP address is the same as the IP address of the computer Ethernet port connected to it.

Solutions

Please follow these steps to troubleshoot the issue:

  1. Check if the following two IP addresses are identical:

    The IP address of the camera that could be discovered

    The IP address of the computer Ethernet port connected to this camera

    • If not, please contact Technical Support.

    • If so, proceed to step 2.

  2. Modify the IP address of the camera or the computer Ethernet port, and then check if the other cameras can be discovered by Mech-Eye SDK or the GenICam client.

    Modify the camera IP address

    Use Mech-Eye Viewer or the IP configuration tool to modify.

    Modify the IP address of the computer Ethernet port

    Refer to Set IP Address on Computer.

    • If all cameras could be discovered, the troubleshooting is completed.

    • If not all cameras could be discovered, please contact Technical Support.

We Value Your Privacy

We use cookies to provide you with the best possible experience on our website. By continuing to use the site, you acknowledge that you agree to the use of cookies. If you decline, a single cookie will be used to ensure you're not tracked or remembered when you visit this website.