软件许可
从2.1.0版本软件起,梅卡曼德使用Sentinel LDK作为软件的许可系统。该许可系统支持硬锁、软锁两种加密形式,同时支持永久许可和临时许可。
梅卡曼德会结合用户实际使用需求,为用户判断将要使用的加密形式,并赋予许可有效期。
软件许可对产品的使用区域进行了限制。如果你获取的是中国大陆许可,则只授权你在中国大陆地区使用授权的产品。如果在其他地区使用,将不提供保修服务,且显示语言仅支持中文。 |
|
下文将对用户如何获取并管理软件许可以及许可常见问题进行介绍。
获得软件许可
-
如果需要使用软锁,联系梅卡曼德销售获取产品密钥。梅卡曼德将通过邮件下发产品密钥,如下图所示。此外,邮件内也会包含用于激活和更新许可的授权管理系统登录页面。
-
如果需要使用硬锁,联系梅卡曼德销售获取硬锁。梅卡曼德将通过随产品附带、邮寄或者现场交付的方式交付硬锁。硬锁已激活许可,将硬锁插入工控机的USB口即可直接使用。
|
管理软件许可
可参考如下指引阅读对应的内容。
激活或更新许可后,可通过检查许可确认许可已激活或更新成功。
激活许可
硬锁交付时已激活许可,可直接使用。若无法使用,可参考交付的硬锁无法直接使用查看解决方法。
如果使用的是软锁,需根据获得的产品密钥自行激活许可,软锁激活方法如下。
-
登录授权管理系统。
进入授权管理系统登录页面,输入产品密钥并单击登录按钮。
-
在线激活许可。
在跳转后的页面右上角单击在线激活按钮,即可激活许可。
若无法连接网络,也可通过离线方式激活许可。具体操作方法如下。
-
打开ACC页面。
打开Sentinel Admin Control Center页面(简称ACC)。
-
生成指纹文件。
在对应的Sentinel锁的操作栏下方单击指纹按钮,生成指纹文件。
生成指纹文件前,需确保表格左侧显示的开发商ID为31772。
-
获取V2C或V2CP文件。
将生成的指纹文件发送给梅卡曼德,然后获取到梅卡曼德返回的V2C或V2CP文件。
-
离线激活许可。
从Sentinel Admin Control Center页面左侧导航栏中进入更新/依附页面,单击选择文件按钮选择从梅卡曼德获取到的V2C或V2CP文件,然后单击应用文件按钮,即可激活许可。
-
指纹文件,即用户传递给梅卡曼德销售的文件,该文件中包含工控机相关信息。
-
V2C(Vendor to Customer)文件,即梅卡曼德销售传递给用户的文件,该文件中包含提供给用户的许可相关信息。
-
V2CP文件,即V2C文件包,包含了多个V2C文件。
-
更新许可
如果临时许可过期或变更授权软件,需更新软件许可。
为软锁更新许可
如果使用的是软锁,更新许可的具体操作方法如下。
-
联系梅卡曼德销售,提出更新许可的需求后,梅卡曼德将更新后台数据。
-
进入授权管理系统登录页面,切换至“许可更新”窗口,单击更新许可按钮,即可更新许可。
若无法连接网络,也可通过V2C或V2CP文件离线更新许可,具体操作方法如下。
-
打开ACC页面。
打开Sentinel Admin Control Center页面(简称ACC)。
-
生成C2V文件。
在对应的Sentinel锁的操作栏下方单击C2V按钮,生成C2V文件。
-
获取V2C或V2CP文件。
将生成的C2V文件发送给梅卡曼德,然后获取到梅卡曼德返回的V2C或V2CP文件。
-
离线更新许可。
从Sentinel Admin Control Center页面左侧导航栏中进入更新/依附页面,单击选择文件按钮选择从梅卡曼德获取到的V2C或V2CP文件,然后单击应用文件按钮,即可更新许可。
-
C2V(Customer to Vendor)文件,即用户传递给梅卡曼德销售的文件,该文件中包含软锁相关信息。
-
V2C(Vendor to Customer)文件,即梅卡曼德销售传递给用户的文件,该文件中包含提供给用户的许可相关信息。
-
V2CP文件,即V2C文件包,包含了多个V2C文件。
-
为硬锁更新许可
如果使用的是硬锁,更新许可的具体操作方法如下。
-
联系梅卡曼德销售,提出更新许可的需求后,梅卡曼德将更新后台数据。
-
将硬锁插入工控机的USB接口。
-
进入授权管理系统登录页面,切换至“许可更新”窗口,单击更新许可按钮,即可更新许可。
在无法联网的情况下,可通过V2C或V2CP文件离线更新许可。具体操作方法如下。
-
打开ACC页面。
打开Sentinel Admin Control Center页面(简称ACC)。
-
生成C2V文件。
在对应的Sentinel锁的操作栏下方单击C2V按钮,生成C2V文件。
-
获取V2C或V2CP文件。
将生成的C2V文件发送给梅卡曼德,然后获取到梅卡曼德返回的V2C或V2CP文件。
-
C2V(Customer to Vendor)文件,即用户传递给梅卡曼德销售的文件,该文件中包含硬锁相关信息。
-
V2C(Vendor to Customer)文件,即梅卡曼德销售传递给用户的文件,该文件中包含提供给用户的许可相关信息。
-
V2CP文件,即V2C文件包,包含了多个V2C文件。
-
-
离线更新许可。
从Sentinel Admin Control Center页面左侧导航栏中进入更新/依附页面,单击选择文件按钮选择从梅卡曼德获取到的V2C或V2CP文件,然后单击应用文件按钮,即可更新许可。
检查许可
激活或更新许可后,可在Sentinel Admin Control Center页面或软件中检查许可。
-
在Sentinel Admin Control Center页面中查看许可信息。
-
在页面左侧进入功能页面,在该页面中查看授权的产品及其有效期。
-
在 Mech-DLK 中检查许可。
进入 Mech-DLK 主界面后,在菜单栏中依次选择
,可在弹出的“关于”窗口中查看有效期,检查许可是否已更新。若许可已更新,检查结束。若许可更新失败,请重新更新许可。若许可仍未更新,请联系梅卡曼德。
常见问题处理
打开软件时报错
-
问题现象
打开被加密的软件后,弹窗报错“Sentinel key not found(H0007)”或“Feature not found(H0031)”。
-
可能原因
未获得软件使用许可(H0007),或软件许可异常(H0031)。
-
解决方法
联系梅卡曼德获得软件许可并激活许可。
无法进入Sentinel Admin Control Center页面
-
问题现象
-
可能原因
-
Sentinel LDK加密驱动未成功安装。
-
Sentinel Admin Control Center页面对应的Sentinel LDK-EMS Service服务未启动。
-
-
解决方法
-
重新下载并安装Sentinel LDK加密驱动。安装完成后,确保在工控机的 中存在已安装的加密驱动。
-
在任务管理器底部单击打开服务按钮,然后在列表中右键单击Sentinel LDK License Manager,在快捷菜单中选择启动,以重新启动Sentinel LDK-EMS Service服务。
上述操作均基于Windows 10,若使用Windows 11,需根据实际情况进行操作。
-
“在线激活”按钮失效
-
问题现象
通过产品密钥在线激活许可时,在线激活按钮失效。
-
可能原因
Sentinel LDK-EMS Service服务对应的URL缺失。
-
解决方法
在Sentinel Admin Control Center页面的 中设置“网络可见性”为所有网络适配,并在底部“EMS URL”处添加“https://license.mech-mind.com.cn:8443/”,然后单击提交按钮。
交付的硬锁无法直接使用
-
问题现象
收到交付的硬锁后,无法直接使用。
-
可能原因
硬锁内的许可信息为空。
-
解决方法
若硬锁内许可为空,需联系梅卡曼德销售获取产品密钥,然后重新激活许可,具体操作如下。
-
将硬锁插入工控机的USB接口。
-
登录授权管理系统。
进入授权管理系统登录页面,输入产品密钥并单击登录按钮。
-
在线激活许可。
在跳转后的页面右上角单击在线激活按钮,即可激活许可。
在无法联网的情况下,可通过V2C或V2CP文件离线激活许可。具体操作方法如下。
-
打开ACC页面。
打开Sentinel Admin Control Center页面(简称ACC)。
-
生成C2V文件。
在对应的Sentinel锁的操作栏下方单击C2V按钮,生成C2V文件。
-
获取V2C或V2CP文件。
将生成的C2V文件发送给梅卡曼德,然后获取到梅卡曼德返回的V2C或V2CP文件。
-
C2V(Customer to Vendor)文件,即用户传递给梅卡曼德销售的文件,该文件中包含硬锁相关信息。
-
V2C(Vendor to Customer)文件,即梅卡曼德销售传递给用户的文件,该文件中包含提供给用户的许可相关信息。
-
V2CP文件,即V2C文件包,包含了多个V2C文件。
-
-
离线激活许可。
从Sentinel Admin Control Center页面左侧导航栏中进入更新/依附页面,单击选择文件按钮选择从梅卡曼德获取到的V2C或V2CP文件,然后单击应用文件按钮,即可激活许可。
-