カメラを接続できない

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問題

Mech-Eye SDK または GenICam 対応ソフトウェアでは使用するカメラを検索できますがこのカメラを接続できません。

考えられる原因

カメラが接続できない原因はいくつかあります。

  • カメラは LAN ケーブルでルーターに接続されていますがコンピュータがルーターのワイヤレスネットワークに接続されています。

  • カメラの IP アドレスとカメラに接続されているコンピュータの LAN ポートの IP アドレスが同じネットワークセグメントにありません。

  • LAN 内にカメラと重複した IP アドレスを持つ他のデバイスがあります (IP アドレスの競合が発生しました)。

  • カメラの MTU 値が 9000 ですが、コンピュータまたはスイッチ/ルーターはジャンボフレームに対応不能または使用していません。

  • コンピュータの複数の LAN ポートの IP アドレスが同じネットワークセグメントにあります。

解決策

重要: Windows オペレーティングシステムにのみ使用できます。Ubuntu オペレーティングシステムを使用する場合、テクニカルサポートにお問い合わせください。

以下の指示に従ってトラブルシューティングを実行してください。

コンピュータがルーターのワイヤレスネットワークに接続されている場合

以下の手順でトラブルシューティングを実行してください。

  1. コントロールパネルを開き、ネットワークとインターネットネットワークの状態とタスクの表示を選択します。

  2. ネットワーク接続には Wi-Fi が表示されているか確認します。

    • 表示されている場合は手順 3 に入ります。

    • 表示されていない場合は次の部分に入ります。

  3. ルーターのワイヤレスネットワークを無効にするか、LAN ケーブルを使用してルーターとコンピュータを接続します。それでMech-Eye SDKまたは GenICam 対応ソフトウェアでカメラを接続できるか確認します。

    • 接続できる場合は、トラブルシューティングは終了です。

    • 表示されていない場合は次の部分に入ります。

カメラの IP アドレスとコンピュータの LAN ポートの IP アドレスが同じネットワークセグメントにない場合

以下の手順でトラブルシューティングを実行してください。

  1. Mech-Eye Viewer でカメラの IP アドレスを確認します。

  2. コンピュータの IP アドレスを設定するを参照してカメラに接続されているコンピュータの LAN ポートの IP アドレスを確認します。

    • コンピュータの LAN ポートは IP アドレスを自動的に取得するに設定された場合、コンピュータの IP アドレスを設定するを参照して LAN ポートに静的 IP アドレスを設定してください。それから手順 3 に進みます。

    • 2つの IP アドレスが異なるネットワークセグメントにある場合、カメラまたはコンピュータの IP アドレスを変更して同じネットワークセグメントに設定してください。それから手順 3 に進みます。

      カメラの IP アドレスを変更する

      Mech-Eye Viewerまたは IP 設定ツールを使用して変更します。

      コンピュータのネットワークポートの IP アドレスを変更する

      詳細については、 コンピュータの IP アドレスを設定する をご参照ください。

    • 2つの IP アドレスが同じネットワークセグメントにある場合は次の内容に進みます。

  3. Mech-Eye SDKまたは GenICam 対応ソフトウェアでカメラを接続できるか確認します。

    • 接続できる場合は、トラブルシューティングは終了です。

    • 表示されていない場合は次の部分に入ります。

IP アドレスの競合が発生した場合

以下の手順でトラブルシューティングを実行してください。

  1. ルータやスイッチなど、カメラ以外のデバイスへのコンピュータの接続を切断します。

  2. Mech-Eye SDKまたは GenICam 対応ソフトウェアでカメラを接続できるか確認します。

    • 接続できる場合、カメラと同じ IP アドレスを使用しているデバイスがあります。手順 3 に入ります。

    • 表示されていない場合は次の部分に入ります。

  3. その中の 1つのデバイスをコンピュータに接続し、Mech-Eye SDKまたは GenICam 対応ソフトウェアでカメラを接続できるか確認します。それからこのデバイスの接続を切断します。カメラができない原因になるデバイスが見つかるまでこの手順を繰り返します。このデバイスはカメラと同じ IP アドレスを使用しています。

  4. このデバイスの IP アドレスを変更するか、Mech-Eye Viewerまたは IP アドレス設定ツールを使用してカメラの IP アドレスを変更します。それから他のデバイスをコンピュータに接続します。

  5. それでMech-Eye SDKまたは GenICam 対応ソフトウェアでカメラを接続できるか再度確認します。

    • 接続できる場合は、トラブルシューティングは終了です。

    • 表示されていない場合は次の部分に入ります。

ジャンボフレームに対応不能/未使用

カメラの MTU 値を 9000 に設定しない場合、この部分の内容を飛ばしてください。
  1. コンピュータのジャンボフレーム機能を使用しているか確認してください。詳細はジャンボフレーム(GenICam)機能の使用をお読みください。

    • 表示されている場合は手順 2 に入ります。

    • それで Mech-Eye SDK または GenICam 対応ソフトウェアでカメラを接続できるか確認します。

      • 接続できる場合は、トラブルシューティングは終了です。

      • できない場合は手順 2 に入ります。

  2. スイッチ/ルーター経由でコンピュータとカメラを接続している場合、手順 3 に入ります。コンピュータとカメラを直接接続している場合、手順 4 に入ります。

  3. スイッチ/ルーターの説明書を確認するかそのメーカーに連絡してジャンボフレーム機能に対応可能かどうか確認します。

    • 対応可能な場合、スイッチ/ルーターの説明書の内容に従ってジャンボフレーム機能を有効にしてください。それでMech-Eye SDKまたは GenICam 対応ソフトウェアでカメラを接続できるか確認します。

      • 接続できる場合は、トラブルシューティングは終了です。

      • 接続できない場合、手順 4 を実行します。

        できる場合に対応可能なスイッチ/ルーターに交換してください。
    • サポートする場合、手順 4 に進みます。

  4. カメラの MTU 値を 1500 に変更します。それで Mech-Eye SDK または GenICam 対応ソフトウェアでカメラを接続できるか確認します。

    • 接続できる場合は、トラブルシューティングは終了です。

    • 表示されていない場合は次の部分に入ります。

コンピュータの複数の LAN ポートの IP アドレスが同じネットワークセグメントにある場合

以下の手順でトラブルシューティングを実行してください。

  1. カメラ以外のデバイスに接続されたコンピュータの LAN ポートを無効にします。

    1. コントロールパネルを開き、ネットワークとインターネットネットワークの状態とタスクの表示を選択します。

    2. アダプターの設定の変更をクリックし、ネットワーク接続ウィンドウが表示されます。

    3. ネットワーク接続ウィンドウで、カメラ以外のデバイスに接続された LAN ポートを右クリックして無効にするをクリックします。

  2. Mech-Eye SDKまたは GenICam 対応ソフトウェアでカメラを接続できるか確認します。

    • 接続できる場合、コンピュータの複数の LAN ポートが同じネットワークセグメントにあります。手順 3 を実行します。

    • 接続できない場合、手順 4 を実行します。

  3. 無効にした LAN ポートの IP アドレスを変更してからまた有効にします。

    1. ネットワーク接続ウィンドウでコンピュータの IP アドレスを設定するを参照して無効にした LAN ポートの IP アドレスを他のネットワークセグメントに設定します。

    2. これらの LAN ポートを右クリックして有効にするをクリックします。それでMech-Eye SDKまたは GenICam 対応ソフトウェアでカメラを接続できるか確認します。

      • 接続できる場合は、トラブルシューティングは終了です。

      • 接続できない場合、手順 4 を実行します。

  4. カメラを再起動:カメラの電源を切断してから入れます。それでMech-Eye SDKまたは GenICam 対応ソフトウェアでカメラを接続できるか確認します。

    • 接続できる場合は、トラブルシューティングは終了です。

    • できない場合にテクニカルサポートお問い合わせください。

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