Camera Disconnected Occasionally

Symptoms

  • 1.8.0 or later: The log of Mech-Vision displayed Failed to get intrinsic parameters from camera serial number.

  • 1.7.4 or earlier: The log of Mech-Vision or Mech-Center displayed Camera IP address get disconnected.

Possible Causes

  • The camera cables are not correctly connected or mounted, or the cables need to be replaced.

  • The network is unstable.

Solution

Please follow these steps to troubleshoot the issue:

  1. Refer to Camera Hardware User Manual and Guidelines for Mounting Camera Cables and check if the camera cables are correctly connected and mounted, without issues such as not fully tightened connector nut or tangling with other cables.

    • If the camera cables are not correctly connected and mounted, please correct the connection and mounting, and then run the Mech-Vision project again to check if the symptom is still present.

      • If not present, the troubleshooting is completed.

      • If still present, proceed to step 2.

    • If the camera cables are correctly connected and mounted, proceed to step 2.

  2. Use Command Prompt to check the stability of the camera network connection:

    1. Open Command Prompt and execute the following command. Replace XXX.XXX.XX.XX with the IP address of the camera.

      ping XXX.XXX.XX.XX -t
    2. Check the printed message in Command Prompt:

      • If Request timed out appeared within a few seconds, the network connection is unstable. Please replace the camera Ethernet cable, or check if the other devices in the network, such as the network switch, are operating properly. Then, run the Mech-Vision project again to check if the symptom is still present.

        • If not present, the troubleshooting is completed.

        • If still present, please contact Technical Support.

      • If Command Prompt only displays content similar to the following, the network connection is stable. Please contact Technical Support.

        Reply from XXX.XXX.XX.XX: bytes=32 time<1ms TTL=64
        Reply from XXX.XXX.XX.XX: bytes=32 time<1ms TTL=64
        Reply from XXX.XXX.XX.XX: bytes=32 time<1ms TTL=64

Related Issues

The following issues might be caused by the same reasons. If you also encountered these issues, after resolving the issue in this topic, you can check if these other issues have been resolved as well.

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