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This section introduces the master-control program for KUKA robots and the procedure of setting up the
communication with a robot through the program.

CONTENTS 1



CHAPTER
ONE

KUKA SETUP INSTRUCTIONS

This section introduces the process of loading the robot master-control program onto a KUKA robot.

The process consists of the following steps:

« Setup the Network Connection

+ Load the Program Files

« Test Robot Connection

Please have a flash drive ready at hand.

+ Check Controller and Software Compatibility

1.1 Check Controller and Software Compatibility

Compatibility requirements are as follows:
+ Controller model: KUKA KR C4, C5

- Controller system software version: KSS 8.2,8.3,8.50r 8.6
- Add-on software package: Ethernet KRL (V 2.2.8, 3.0.3 or 3.1.2.29)

The correspondance between KSS and Ethernet KRL versions is as follows:

KSS version | Ethernet KRL version
8.20r83 228

8.5 3.0.3

8.6 3.1.2.29

+ Mech-Mind Software Suite: latest version recommended

Note: All teach pendant actions in this chapter are performed on KSS 8.6. The specific steps and menu
selections may differ slightly in older versions of system software.
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1.2 Setup the Network Connection

1.2.1 Hardware Connection

Plug the Ethernet cable into:
+ An Ethernet port on the IPC
+ The X66 port on KR C4 compact and KLI port on other KR C4 controllers

-....

1.2. Setup the Network Connection 3
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1.2.2 IP Configuration

To allow communication between the IPC and the robot controller, both must have an IP address in the
same subnet. This means that the first three numbers of the IP addresses should be the same. For
example, 192.168.100.7 and 192.168.100.2 are in the same subnet.

1. Check the IP address of the IPC: please use the ipconfig command in Commmand Prompt or Power-
Shell to check the IP address.

2. Switch to expert mode:

1. Presson , and then select Configuration — User group.

1.2. Setup the Network Connection 4



Mech-Mind User’'s Manual

0 a 9:40:51 AM 5/11/2022 LOS 120
= The logged-on user switched from Operator to Administrator.

Display

Status keys

Diagnosis

User group

Start-up

Miscellaneous

Shutdown

Safety configuration

Help

Brake test configuration

Quick access

Machine configuration

Collision detection

Configuration * Miscellansous * Language

Display * Variable * Cyclical flags

Configuration * Miscellanzous * Event planner

Start-up » Calibrate * Tolerances

2. Select Expert, enter the password (the default password is kuka), and press on Log on.

1.2. Setup the Network Connection
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0 a 9:46:54 AM 5112022 LOS 120
= The logged-on user switched from Administrator to Operator.

Operator (default) is logged on.

Select a user group:

Operator (Default)

User

Safety recovery technician
A2

Safety maintenance technician

Administrator

A3

Password:

I
EEEEEEE

P P

Lz

A6

3. Presson , and then select Start-up — Network configuration.

1.2. Setup the Network Connection 6
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| 100 4. T10
ﬂ-ﬁs w| & |# o o

8 o a 9:46:54 AM 5112022 LOS 120 -
p ol The logged-on user switched from Administrator to Operator.

Start-up wizard

Configuration Supplementary load data

Display Tool/base management

Diagnosis Calibrate

Software update

Service

Robot data

Metwork configuration

Additional software

Rights management

Quick access

Configuration * User group

Configuration * Miscellaneous * Language

Display * Variable » Cyclical flags

Configuration * Miscellanzous * Event planner

4. Input an IP address in the same subnet as that of the IPC, and then press on Save. In the next two
pop-up windows, press on Yes and OK, respectively.

1.2. Setup the Network Connection 7
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a o a 10:41:27 AM 5/11/2022 LOS 120 -
P ol The logged-on user switched from Cperator to Expert.
l

o MNetwork configuration

Windows interface (virtuals)

Address type: Fixed IP address

Standard gateway:

The Windows interface is the network interface via which WorkVisual communicates with
the controller. (If PROFINET is used without an advanced configuration, a static IP must

be used.)

@

1.2. Setup the Network Connection
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Network configuration

@ Would you like to save the changes?

& Configuration has been modified. The changes will be applied after the next cold

start with "Reload files"!

5. Restart the robot to finish setting the IP address:

1. Press on , and select Shutdown.

1.2. Setup the Network Connection 9
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| 100 4. T10
11 = 1w K |# L o

a o a 10:47:26 AM 5/11/2022 LOS 120 -
p ol The logged-on user switched from Expert to Operator.
5

Slel - £

Main menu

Configuration

Display

Diagnosis

Start-up

Shutdown

Quick access

Shutdown

Start-up * Network configuration

Configuration * User group

Configuration * Miscellaneous * Language

2. Press on Reboot control PC.

1.2. Setup the Network Connection 10
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I Pk 100 ‘ 2
= | o P BN
a o a 8:43:39 AM 5/13/2022 LOS 120 -
P ol The logged-on user switched from Cperator to Expert.
6

@ Default settings for shutdown

Start type

‘DCuldslart ir

Power-off wait time [s]

Power-fail wait time [5]

@ Settings for next shutdown

HI ||| | Dwaﬁdehﬁ

8 P—
‘Dneluadﬁhs Hwﬁ"‘m‘

@ Shutdown actions

@ Drive bus

il o

1.2. Setup the Network Connection
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1.3 Load the Program Files

Attention: Before operating the robot, please follow the backup instructions below to back up the
system.

1.3.1 Backup

Note: Make sure you have switched to expert mode on the teach pendant. For instructions, see step 2 in
IP Configuration.

1. Plug the flash drive for storing the backup file to the controller, and make sure that the flash drive
shows up on the teach pendant.

1.3. Load the Program Files 12
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< >

2 Object(s)

LLIL T

2. Presson , and then select File — Archive — USB (cabinet).

1.3. Load the Program Files

13
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I 100
o & | n Mg

:I i
]
0
0

USB (KCP)

Configuration Restore USB (cabinet)

Display Backup Manager Metwork

Diagnosis Logbook

Start-up

Shutdown

Quick access

Configuration * Miscellansous * Language

File » Archive » USB (KCP) » All

File » Archive * USE (cabinet) * All

Help » Info

3. After selecting USB (cabinet), select All in the last column.

1.3. Load the Program Files 14
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()8 s O | & | R
&= 10

1]
: ) - =~
0
0
| _

4|

LISR (rahineat)

USB (KCP)

Restore

Backup Manager

Quick access

Configuration * Miscellansous * Language

File » Archive » USB (KCP) » All

File » Archive * USE (cabinet) * All

Help » Info

4. Press on Yes in the pop-up window to start the backup process.

1.3. Load the Program Files 15
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8:26:33 AM 9/26/2022 FILEHANDLER. 35

® Do you really want to archive the selected file(s)?

s oo

5. The following message is displayed when backup is in process. Once the backup is completed, this
message disappears, and a ZIP file is created in the flash drive.

Contents of: PCRC-2RL7HHTTRE (KRC:\)
Mame | Bx... | Comment

1.3.2 Prepare the Files

The program files are stored in the installation directory of Mech-Mind Software Suite.

Navigate to xxx\Mech-Mind Software Suite-x.x. x\Mech-Center\Robot_Server\Robot_FullControl\kuka\kuka_new,
and copy all the program files to your flash drive.

1.3.3 Load the Files to the Robot

Note: Make sure you have switched to expert mode on the teach pendant. For instructions, see step 2 in
IP Configuration.

1. Plug the flash drive to the controller.
2. Select the flash drive, and locate the above files.

3. Select mm_motion.xml, press on Edit, and then select Copy.

1.3. Load the Program Files 16
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9 ]

B o Navigator
=| Filter: Detail

B o a 11:06:02 AM 5/11/2022 LOS 120 -
P =\ The logged-on user switched from Operator to Expert.
3

> 100

= w| & “'Tig'”'” o0

~=pnpnA

) KUKA_DISK (C:\)

E;j test_simulate
@J" (ARCHIVE:\)

<

:— PCRC-2RL7HHTTRE (KRC:\)

Ej System Volume Informat]

Cut

Copy

Paste

Delete

Duplicate

Archive

Rename

Properties

Filter

Select

Cancel program

Reset program

2 Object(s) selected

|866 Bytes

L=

= )

4. Navigate to C./KRC/ROBOTER/Config/User/Common/EthernetKRL, press on Edit, and then select

Paste.

1.3. Load the Program Files
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~=pnpnA

Navigator
=| Filter: Detail

> 100
&= 10

MotionDrivers

PersistCIB

PersistPC

PersistPDS

PersistRDC

VxWin

k| & g o

a o a 11:06:02 AM 5/11/2022 LOS 120 -
P ol The logged-on user switched from Cperator to Expert.
6

Cut

Copy

Paste

Delete

Duplicate

Archive

Rename

Properties

Filter

Select

Cancel program

Reset program

5. Navigate back to the flash drive, and repeat steps 3 and 4 for mm_status.xml.

6. Navigate to KRC:/R1, and press on New.

1.3. Load the Program Files
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HAMDLER on external .

@ : :
5 Obje |
) o) sl (o5 ol i

==

7. Input mechmind for the folder name, and press on OK.

1.3. Load the Program Files 19
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; . . . . . . | : A6

8. Navigate back to the flash drive, and copy and paste the other 5 files to KRL:/R1/mechmind.

Note: Long-press and drag to select multiple adjacent files.

1.3. Load the Program Files 20
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I Pk 100 ‘ E;

= (P E S L
0 a 12:18:39 PM 5/11/2022 LOS 120 -
ol The logged-on user switched from Cperator to Expert.

2
B o

[x]
a

Fitcer: Detail

J_ PCRC-2RL7HHTTRE (KRC:\) e

dat  MM_SERVER

sub

MM_SERVER

1 Object(s) selected [423 Bytes

) o o o o )

1.3. Load the Program Files
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1.3.4 Set Autostart for Background Porgram

Note: Make sure you have switched to expert mode on the teach pendant. For instructions, see step 2 in
IP Configuration.

1. Presson - and then Display/Assign.

(Vg sfromm

All SUBMIT interpreters

» 100
& 10

0 KUKA_DISK (C:\)

e MM_USB (F:\)

(ARCHIVE:)

1 Object(s) selected [423 Bytes

o o] L o L L

1.3. Load the Program Files 22
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2. Press on Cold start configuration, and then press on the text box to the right of SYS.

0
9 —-—n;l;ﬂnl

I @ 12:21:16 PM 5/11/2022 LON 3
B Incorrect password entered!
3

- SUBMIT interpreter

Fitcer: Detail

MName
PCRC-2ZRL7HHTTRE (KRi

MM_SERVER

MM_SERVER

<
1 Object(s) selected [423 Bytes

i o o o o o s

3. Select the blank in the drop-down menu, and then press on the check-box in Autostart to uncheck it.

1.3. Load the Program Files 23
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0 ﬂ 12:21:16 PM 5/11/2022 LON 3
Incorrect password entered!
SUBMIT interpreter

Fitcer: Detail

:- PCRC-2RL7HHTTRE (KRL

<

MM_SERVER

MM_SERVER

1 Object(s) selected

o o o o ]

4. Similarly, select mm_server from the drop-down menu for EX1, and make sure Autostart is checked.

1.3. Load the Program Files
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| 100
B -

a o a 12:21:16 PM 5/11/2022 LON 3
B o Incorrect password entered!

- SUBMIT interpreter

mm_sernver

Fitcer: Detail

:- PCRC-2RL7HHTTRE (KRL

MM_SERVER

MM_SERVER

<
1 Object(s) selected [423 Bytes

o o o o ]

5. Press on Current display/assignment, press on the text box to the right of SYS, and then press
Deselect.

1.3. Load the Program Files 25
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e+ | P RN G L

:I E -

~|” SUBMIT interpreter

[

Fitcer: Detail

:- PCRC-2RL7HHTTRE (KRL

MM_SERVER

MM_SERVER

<
1 Object(s) selected [423 Bytes

i o o o o )

6. Press on the text box to the right of SYS again, and select the blank in the drop-down menu.

1.3. Load the Program Files 26
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I 100 g, T?
BRI 5 4 ¢ 2w o

:I -

~|” SUBMIT interpreter

mm_server

MM_SERVER

MM_SERVER

<
1 Object(s) selected [423 Bytes

) o o Lo o )

7. Similarly, select mm_server from the drop-down menu for EX1, and press on Select/Start.

1.3. Load the Program Files
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BENEN . 4 ¢ 2w

:I -

~|” SUBMIT interpreter

mm_sernver

MM_SERVER

MM_SERVER

<
1 Object(s) selected [423 Bytes

o o o o ]

1.3. Load the Program Files
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1.3.5 Select Foreground Program

1. Open the mechmind folder, select mainmodule.src, and then press on Select.

Fitcer: Detail

I PCRC-2RL7HHTTRE (KRC:\)

dat

MM_SERVER

sub  MM_SERVER

1 Gbject(s) selecte’ ‘ [420 Bytes ’
S N =y e P P

2. The following should appear on the screen.

1.3. Load the Program Files 29
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U | - M 5 ] H p 1["] . -
. [ 1]
6 JR1/MAINMODULE n & 10 k| # B?

B o a 12:30:24 PM 5/11/2022 KS501356 =
LB coart key required
1

MECHHMIHD KUKA 4.1

; WAIT FOR $IH_HOME

3={>TP HOHE Vel=10@ % DEFAULT

INIT()

WHILE (TRUE)

MHM_CONTROL{1)

ENDWHILE

BP 3 |KRC YR1I\MECHMIND\MAINMODULE.SRC |Lr1 3, ColO

oo o e, 7 o

1.3. Load the Program Files
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1.3.6 Run Program in AUT Mode

1. Turn the key switch to horizontal, select T1 on the screen, and then turn the switch back to vertical.

2. Check the icon to the right of

I
- If it looks like EEE, then skip this step.

0 N
- If it looks like L | then press on it and select in the drop-down window.

1.3. Load the Program Files 31
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Motion enable from Safety

1 Object(s) selected [441 Bytes

i o o o o o )

3. Press on the enabling switch (either one of three) on the back of the pendant and E on the
front at the same time to move the robot back to Home position. When the screen displays a mes-

R
sage saying Programmed path reached (BCO),and © turns red, release the enabling switch and

1.3. Load the Program Files 32
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Note: Set an appropriate velocity for the robot before moving it, and observe its motion carefully to

avoid accidents.

0

[R1/MAINMODULE
0 @ 12:32:40 PM 5/11/2022 KSS01350
Wl Programmed path reached (BCO)

Originator: /R1/MAINMODULE

MECHHMIHD KUKA 4.1

1

4. Switch to AUT mode as described in step 10, and press on ke Ao start running the master-control

program (. should turn green).

e e PRI T

0
6 /R1/MOTION CONTROL &&= 10
a o 9 12:33:26 PM 5/11/2022 LOS 120 -
0 QK Confirm all
| The logged-on user switched from Expert to Operator.
n z

Editor
19 INIT() )

33
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1.4 Test Robot Connection

1.4.1 Configure Robot in Mech-Viz

1.

2
3
4
5

Open Mech-Viz, click New project to create a new project.

. Select the robot model in use in the next page.
. Save the project by pressing Ctrl + S.
. In the toolbar, change the Vel. (velocity) and Acc. (acceleration) parameters to 5%.

. Right-click the project name in Resources and select Autoload Project.

1.4.2 Configure Settings in Mech-Center

1.
2.

Open Mech-Center and click on Deployment Settings.

Go to Robot Server, and make sure Use robot server is checked.

3. Check if the robot model displayed next to Robot type in Mech-Viz project matches the one in use.
4. Set the Robot IP address, and click Save.

1.4.3 Connect to Robot in Mech-Center

1. Click Connect Robot in the Toolbar.

2. The robot is successfully connected if:

- A message saying Robot: server connected to the robot shows up in the Log panel, and

+ Arobot icon with the robot model shows up in the Service Status panel.

1.4.4 Move the Robot

1. In Mech-Viz, click Sync Robot in the toolbar to synchronize the pose of the real robot to the simulated

robot. Then, click Sync Robot again to disable the synchronization.

2. Click the Robot tab in the lower right, and change the joint position of J1 slightly (for example, from

0° to 3°). The simulated robot will move accordingly.

3. Click Move real robot, the real robot should move accordingly.

Attention: When moving the robot, please pay attention to safety hazards. In the case of an emer-
gency, press the emergency stop button on the teach pendant!

1.4. Test Robot Connection
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CHAPTER
TWO

2.1 Master-Control Programs

KUKA PROGRAM DESCRIPTION

Program

Description

mm_server.sub

Background program for receiving data from Mech-Center and sending robot pose,

signal and status data

mm_server.dat

Data file for the background program

mo- Foreground program for controlling and moving the robot
tion_control.src

mainmod- Foreground main module of the master-control program
ule.src

mainmod- Data file for the main module

ule.dat

mm_status.xml

Configuration file for communicating robot status

mm_motion.xml

Configuration file for communicating robot motion

2.2 Internal Flags

Internal flag | Description

SFLAGIT] Flag indicating that mm_motion has successfully connected
SFLAGI2] Flag indicating that mm_motion has received data

SFLAGIH] Flag indicating that mm_status has successfully connected
SFLAGI6] Flag indicating that mm_status has received data

2.3 10s

|0 occupied | Signal

DI (16) SIN[1]-SIN[16]

DO (16) SOUT[1]-S0UT[16]
DI (64) SIN[1]-SIN[64]

DO (64) SOUT[1]-SOUTI[64]

35
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